Are you experiencing problems with our virtual tour viewer?
< back

There is only one recorded issue:

1. Some older versions of Internet Explorer are NOT compatible with HTML5. If you have IE 10 or older, you need to update to a newer browser. We recommend Chrome, Firefox, Safari, and IE 11; in that order.

You can download Safari from apple for free here http://support.apple.com/downloads/#safari/

You can download Google Chrome for free here https://support.google.com/chrome/answer/95346?hl=en/

You can download Firefox from Mozilla for free here http://www.ez-download.com/lp/firefox/7vj3rjufd9490d4otol6mrpvmbt1ctbpmso66sd2iamr1ejtoe60-ab09e62a9bca829430bc64b65d3606d6/?/

You can download Internet Explorer 11 from Microsoft for free here //http://windows.microsoft.com/en-us/internet-explorer/download-ie/

If you need assistance, please contact us.